Website unavailable in some regions
Incident Report for Statusbrew
Resolved
The issue has been resolved
Posted 25 days ago. Aug 27, 2019 - 21:04 UTC
Monitoring
We were notified an hour ago that the website was not available in a few regions.
We are aware of the issues and it will get resolved in the next 15 minutes.
Posted 25 days ago. Aug 27, 2019 - 20:59 UTC