Degraded Performance in Adding Social Accounts
Incident Report for Statusbrew
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 30, 2019 - 09:13 UTC
Investigating
Our site has to run urgent unplanned maintenance due to which it will some users might not be able to add social accounts. We apologize for the inconvenience.
Posted 3 months ago. Jul 30, 2019 - 09:09 UTC
This incident affected: Statusbrew Admin | Web (App Settings).